Un client Google Drive pour Linux : Insync (MAJ)

Rédigé par Pedro CADETE / 23 commentaires

p3ter.fr - client google drive linux : insync

Google n'ayant pas encore développé de client Linux pour Drive, les solutions alternatives se multiplient. Grive a eu son succès a son lancement, mais les mise à jours du projet se font attendre et la synchronisation automatique n'est toujours pas possible. J'ai donc essayé (et adopté) une autre solution : Insync.


MAJ 22/10/2013 : Une alternative libre et gratuite est disponible, il s'agit de SyncDrive.

MAJ 30/07/2013 :
Insync est disponible en version stable 1.0 sous Linux. Il faudra désormais acheter une licence permanente à 9.99$ ou débourser 5$ par an.

MAJ 27/06/2013 :
La version 0.10.8 est une bêta basée sur la version stable 1.0. C'est pourquoi, elle est bien limitée à 15 jours. Puisqu'il s'agit encore d'une bêta, il est possible de demander plus de temps d'essai : explications ici.

MAJ 27/06/2013 :
Suite à la mise à jour de la bêta 0.9 en 0.10.8, Insync ne fonctionnait plus sur mon Ubuntu. J'ai du désinstaller (sudo apt-get purge insync-beta-ubuntu) et réinstaller. Je met à jour cette article avec les nouveaux écrans d'Insync. Le bêta continue d'être gratuite cependant Insync nous envoie un mail, après l'installation, indiquant qu'on bénéficie de 15 jours d'essais. Avec un peu de chance il s'agit la d'un mail générique envoyé à tout les utilisateurs installant Insync, espérons que la bêta fonctionne toujours après 15 jours. Wait and see...

MAJ 31/05/2013
: Insync devient payant avec la version 1.0 (5€ par an). Cependant la version Linux étant toujours en beta (0.9) il est encore possible de l'utiliser gratuitement.

MAJ 13/04/2013 : Un repos pour Fedora est disponible (voir ci-dessous). Les paquets pour Xfce et Mate ont été ajoutés aux repos Ubuntu, Debian et Linux Mint. Insync est désormais disponible pour ArchLinux via le repos AUR.

MAJ 26/10/2012 : Un dépôt officiel est désormais disponible pour Ubuntu, Debian et Linux Mint. J'ai mis à jour la procédure d'installation.

MAJ 11.10.2012 : La version 0.9.24 permet désormais d'ouvrir vos documents au format Google Doc. avec Libre Office, ou une autre suite bureautique, puisque désormais Insync télécharge ces fichiers au format Open Document (.odt). Cette version va aussi vous permettre, entre autre, de mettre en pause la synchronisation.

Ce projet est beaucoup plus abouti que Grive et propose la synchronisation automatique (à la Dropbox) ainsi que le téléchargement des fichiers de type Google Documents.

Installation

Insync est disponible pour Ubuntu (natty, oneiric, precise, quantal), pour Debian (squeeze, lenny) et pour Linux Mint (lisa, maya) via le dépôt ci-dessous.

Ubuntu, Debian et Linux Mint
Ajouter le dépôt
#Ubuntu
echo "deb http://apt.insynchq.com/ubuntu $(lsb_release -cs) non-free" | sudo tee /etc/apt/sources.list.d/insync.list

#Debian
echo "deb http://apt.insynchq.com/debian $(lsb_release -cs) non-free" | sudo tee -a /etc/apt/sources.list

#Linux Mint
echo "deb http://apt.insynchq.com/mint $(lsb_release -cs) non-free" | sudo tee /etc/apt/sources.list.d/insync.list
Ajouter la clé et update des sources
wget -O - https://d2t3ff60b2tol4.cloudfront.net/services@insynchq.com.gpg.key | sudo apt-key add -
sudo apt-get update
Installer le paquet
#Unity
sudo apt-get install insync-beta-ubuntu

#GNOME Shell
sudo apt-get install insync-beta-gnome

#Cinnamon
sudo apt-get install insync-beta-cinnamon

#KDE4
sudo apt-get install insync-beta-kde

#MATE
sudo apt-get install insync-beta-mate

#Xfce
sudo apt-get install insync-beta-xfce


Fedora
Commencez par créer un fichier insync.repo dans le répertoire /etc/yum.repos.d/. Ajoutez le contenu ci-dessous au fichier insync.repo.
[insync]
name=insync
repo baseurl=http://yum.insynchq.com/fedora/
gpgcheck=1
gpgkey=https://d2t3ff60b2tol4.cloudfront.net/repomd.xml.key
enabled=1
repo_gpgcheck=1
metadata_expire=60m

Ajoutez la clé publiv GPG
sudo rpm --import https://d2t3ff60b2tol4.cloudfront.net/repomd.xml.key 

Et installez le paquet adéquate
#Cinnamon
sudo yum groupinstall insync-beta-cinnamon

#GNOME Shell
sudo yum groupinstall insync-beta-gnome

#KDE 4
sudo yum install insync-beta-kde

ArchLinux
Insync est disponible dans le repos AUR. Commencez par installer AUR et Yaourt (chapitre 4.6).
yaourt -S insync 

Utilisation

Après installation des paquets, lancez Insync depuis un terminal ou depuis le menu des applications. Ensuite authentifiez vous avec votre compte Google Drive.


Vous pouvez démarrer la synchronisation, avec les paramètres par défaut, en cliquant sur "Start syncing".


Une icône dans votre barre d'état va apparaître et à la manière de Dropbox vous pourrez suivre la synchronisation de vos fichiers.

p3ter.fr - client google drive linux : insync



Un dossier est créé dans votre dossier personnel. Il porte le nom de votre adresse mail. Si vous souhaitez le changer rendez-vous dans les paramètres de votre compte, accessibles depuis l’icône de la barre des tâches. Dans mon cas j'ai choisi d’appeler le dossier "Google Drive". Insync s'occupe tout seul de le renommer.


De plus, depuis les paramètres d'Insync, vous pouvez, par exemple, choisir de démarrer ou pas Insync automatiquement à l'ouverture de session.



En conclusion

Voila un client Google Drive qui va vous permettre d'approcher les fonctionnalités du client officiel pour Windows et Mac. Les fichiers Google Document sont téléchargés au format odt, ods et odp et sont donc lisibles par n'importe quel suite bureautique. L'autre intérêt d'Insync est qu'il est multi-compte. Vous pouvez synchroniser en local les donner de plusieurs comptes Google Drive.

Le projet évolue très vite, mais la version Linux est encore en bêta. Quant aux versions Windows et Mac elles sont payantes et lorsque la version Linux ne sera plus en bêta, il faudra alors débourser 5$ par an (pour la version complète), ce qui n'est pas excessif à mes yeux (plus d'informations sur le site officiel). Par ailleurs, Insync existe aussi sous IOS et Android.

En revanche et c'est important : Insync est un logiciel propriétaire...

Site officiel : https://www.insynchq.com/
Installation : https://www.insynchq.com/linux

Écrire un commentaire

Quelle est la troisième lettre du mot jarv ? :

23 commentaires

Gravatar
#1 samedi 22 septembre 2012 @ 09:32 dominique0796 a dit :
Salut,
Merci pour cet article !
Juste au passage tu utilises encre aptitude ?
Personnellement je suis sous Ubuntu et utilise toujours apt-get, mais il me semble que Debian à éadopté depuis un petit bout de temps déjà la syntaxe apt-get ... non ?
Gravatar
#2 mardi 25 septembre 2012 @ 17:38 P3ter a dit :
@dominique0796 : Salut. Aptitude est une interface à apt-get et gérerait mieux les dépendances des paquets (à confirmer). Historiquement apt-get a été créé pour Debian (d'où l’extension des paquets : .deb). Ensuite je ne sais pas honnêtement si on peut mélanger les deux (un coup avec apt-get et la fois suivante avec aptitude) sans risquer de casser une dépendance. Les options sont les mêmes à quelques différences près (j'ai rédigé un article "mémo" sur les syntaxes des gestionnaires de paquets). Si quelqu'un a plus d'éléments que moi sur ce sujet qu'il n'hésite pas à partager ;)
Gravatar
#3 lundi 01 octobre 2012 @ 21:22 yklikafon a dit :
excellent tuto. Très efficace. Insync fonctionne parfaitement.
Gravatar
#4 dimanche 06 janvier 2013 @ 23:01 Lanfeust a dit :
Bonjour, excellent tuto. Devrais être mis en lien depuis le site officiel.
A noter : dans gnome, on le trouve dans le menu Applications > Internet
ça se passe sous Utilisation, lancer lnsync
Puis "Outils système" > Préférences > "Applications au démarrage" pour la capture d'écran. Sinon, pile poil.
Gravatar
#5 lundi 07 janvier 2013 @ 09:35 P3ter a dit :
@Lanfeust : Bonjour, oui effectivement j'ai oublié de préciser pour le menu "Applications au démarrage". Merci à toi !
Gravatar
#6 vendredi 11 janvier 2013 @ 21:32 racoon97 a dit :
Parfait, c'est exactement ce qu'il me fallait.
Gravatar
#7 samedi 06 avril 2013 @ 12:15 Theseb a dit :
Bonjour,

Très bon tuto, milles merci, je n'arrivais pas à installer Grive sur mon debian squeeze. Grace à insync, je réussi à faire ce que je voulais.
Par contre, l'icone n’apparaît pas dans la barre d'état... une solution ?

Merci
Gravatar
#8 dimanche 07 avril 2013 @ 13:24 Pedro CADETE a dit :
@Theseb : Bonjour, es-tu sur que Insync est en cours d'exécution ? Pour le lancer à la main il faut tapper la commande "insync" et l'icône (ou l'applet) doit apparaitre. Tu es sous quelle distribution et avec quelle environnement de bureau (unity, xfce, gnome-shell, kde, ...) ? Car selon l'environnement de bureau le paquet à installer et différent. Plus d'info ici : https://www.insynchq.com/linux.
Gravatar
#9 lundi 08 avril 2013 @ 10:11 Theseb a dit :
Bonjour Pedro et merci pour ta réponse.
J'ai du installer insync en téléchargeant et installant (GDebi) le paquet insync-beta-gnome-cinnamon-common_0.9.41_i386.deb car par le terminal, je recevait un message d'erreur :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
insync-beta-gnome : Dépend: gnome-shell mais il n'est pas installable
E: Paquets défectueux

J'ai ajouté insync dans la liste des applications au démarrage. De plus la synchronisation de mes fichiers se fait. Je pense donc que l'appli est en cours d’exécution.
Je suis sous debian squeeze avec GNOME 2.30.2.
A l'install avec GDebi, j'obtint le message comme quoi la même version est déjà présente dans un depot, qu'il n'est pas conseillé de l'installer manuellement, mais j'ai insisté.

Merci
Gravatar
#10 mardi 09 avril 2013 @ 15:49 Pedro CADETE a dit :
@Theseb : "Pedro" ou "P3ter", c'est la même personne :-p Pour le coup c'est normal que tu ne vois pas l'applet en haut, car tu as dû installer la version cinnamon alors que tu sembles utiliser gnome. Néanmoins, "gnome-shell" ne semble pas être installé. Donc au final, tu es sur quel environnement ? Unity, Gnome3, KDE ?? Si tu es sur Unity, il faut installer le paquet "insync-beta-ubuntu".
Gravatar
#11 mercredi 10 avril 2013 @ 13:43 Theseb a dit :
Bonjour,
Je suis sous Gnome 2.30.2

Merci
Gravatar
#12 mercredi 10 avril 2013 @ 14:03 Theseb a dit :
voici mon sources.list

# deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ - Official i386 CD Binary-1 20120512-13:45]/ squeeze main

# deb cdrom:[Debian GNU/Linux 6.0.5 _Squeeze_ - Official i386 CD Binary-1 20120512-13:45]/ squeeze main

deb http://ftp.fr.debian.org/debian/ squeeze main
deb-src http://ftp.fr.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

deb http://ftp.us.debian.org/debian squeeze main contrib non-free


# squeeze-updates, previously known as 'volatile'
deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main

deb http://apt.insynchq.com/debian squeeze non-free


wget -O - https://d2t3ff60b2tol4.cloudfront.net/services@insynchq.com.gpg.key | sudo apt-key add -


Lorsque je veut installer le paquet, j'obtiene l'erreur dite plus haut.
Gravatar
#13 samedi 13 avril 2013 @ 13:56 Pedro CADETE a dit :
@Theseb : Ton erreur est normale, puisque le paquet insync-beta-gnome et prévu pour Gnome 3. Tandis que Cinnamon est un fork de Gnome 2, si je dit pas de bétise, tout comme Mate. Ainsi, essai aussi d'installer le paquet insync-beta-mate. Sinon regarde si tu peux pas ajouter l'applet Insync toi même en faisant un clique droit sur ta barre pour la personnaliser, peut-être que l'applet d'Insync sera dans la liste des éléments que tu peux ajouter à ta barre.
Gravatar
#14 samedi 13 avril 2013 @ 14:45 Theseb a dit :
Bonjour, j'avais essayé d'ajouter l'applet mais il est absent dans la liste. sinon pour l'install de Mate, cela ne fonctionne pas :

# sudo apt-get install insync-beta-mate
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
insync-beta-mate : Dépend: libappindicator3-1 mais il n'est pas installable
Dépend: python-caja mais il n'est pas installable
Gravatar
#15 lundi 15 avril 2013 @ 19:27 Pedro CADETE a dit :
@Theseb : Bonjour. Je suis désolé, je suis a sec d'idée et j'ai rien trouvé sur le net. Essais d'envoyer un mail au support (en anglais) support @ insynchq.com, en leur expliquant que tu es sous Debian avec Gnome 2 et que tu as installé le paquet pour cinnamon (le seul qui marche dans cette configuration), mais que tu n'as pas l'applet dans la barre de tâche.
Gravatar
#16 lundi 15 avril 2013 @ 20:10 Theseb a dit :
Merci beaucoup pour ton aide et ton dévouement. Je le ferai et te tiendrai au courant si cela t’intéresse ...

Bien cordialement.
Gravatar
#17 mardi 16 avril 2013 @ 09:35 Pedro CADETE a dit :
@Theseb :Oui oui, n'hésites pas à venir partager leur réponse ici ;-)
Gravatar
#18 mercredi 29 mai 2013 @ 09:24 Thomas a dit :
Bonjour, Merci pour la découverte de cet outils. Mais à voir leur site, il semblerait que ce soit payant? Est-ce que je me trompe?
Gravatar
#19 vendredi 31 mai 2013 @ 17:46 Pedro CADETE a dit :
@Thomas :Bonjour, effectivement depuis la nouvelle version (1.0) Insync devient payant (5€ par an). Mais pour le moment la version Linux étant toujours en 0.9, il est encore possible de l'utiliser gratuitement.
Gravatar
#20 mercredi 26 juin 2013 @ 22:52 yoann a dit :
Bonjour,
Pour ma part, à la connexion j'ai reçus un mail me disant que je disposais de 15 jour gratuit, alors que la béta est annoncé gratuite.

De plus Fédora 17 m'annonce un problème avec le paquet insync.
Gravatar
#21 jeudi 27 juin 2013 @ 19:18 Pedro CADETE a dit :
@yoann : Bonjour, effectivement je viens de faire un test en installant la nouvelle beta (v0.10.8) et j'ai moi aussi reçu ce mail. Peut-être que la beta fonctionnera tout de même après 15 jours...
Gravatar
#22 jeudi 27 juin 2013 @ 23:27 Pedro CADETE a dit :
Finalement, la limite des 15 jours est bien réelle (voir mes mises à jour en haut de l'article).
Gravatar
#23 samedi 15 novembre 2014 @ 10:57 nogoogl a dit :
Le plus simple pour installer c'est à l'aide de ce lien : https://www.insynchq.com/

P3ter.fr